Using VS 2012 update 3 and MVC 4

Aug 11, 2013 at 3:19 PM
Edited Aug 11, 2013 at 3:23 PM
Although I have setup the web.config file as you specified in the documentation, it still throws ArgumentException: "Unable to find the requested .Net Framework Data Provider. It may not be installed." in InitializeSimpleMembershipAttribute class (the default MVC Internet application template).
Am I doing something wrong or is there any known issue in this case? Thanks

EDIT: Forgot to mention that I have added the providerName attribute to the connectionstring item in web.config, otherwise the error thrown would say that no providerName attribute specified for the connection string. The provider name I specified is MongoMembershipProvider.
Aug 11, 2013 at 6:28 PM
Edited Aug 11, 2013 at 6:28 PM

This Membership Provider is using MOngoDB that is schemaless NoSQL database. InitializeSimpleMembershipAttribute that is located in template is done for MEmbership that uses Sql Server. Before using membership they need to crete database and using classes that are inside .NET framework for that. You need to remove that filter at all and this error must be resolved.

Aug 11, 2013 at 7:32 PM
Edited Aug 11, 2013 at 7:32 PM
This seems like an workaround at a certain extent. I have removed the [InitializeSimpleMembership] attribute from the AccountController so the above mentioned class is not referenced anymore. The account controller seems to create my account in the MongoDB database, which is great. When I further go to display the Todo lists, it errors again from the same reason in the TodoListController, GetTodoLists() method. So the provider is again not found.. althout I can login (thus check my credentials against my database).
The project I use is the default MVC4 application template, Single Page app. The internet application template I mentioned above works fine without any changes, other than those needed by the provider and documented here.
The sample app included zip downloaded from here works just fine with the same settings (using my database, of course).
Aug 11, 2013 at 7:46 PM
If you can share your solution with me, i can take a look and help with finding error. If it gives the same error, maybe there is attribute on ToDoController? Or TodoList uses Sql Db that is not created? Really not much info to diagnose.
Aug 11, 2013 at 7:51 PM
Of course, I would appreciate any help. It is the default VS 2012 MVC 4 Single app template, anyway. I added the MongoDB driver reference and the ExtMongoMembership one, also changed the web.config accordingly. I have a local MongoDB instance running which the app should connect to. I have uploaded the project with all the binary references to . Thanks for taking the time to look into this.
Aug 11, 2013 at 8:32 PM
So i took a look at solution. There are few mistakes.
1) Please delete InitializeSimpleMembership from project
2) in this app you put "name=mongodb" inside TodoItemContext.cs. This is wrong. This class is dataaccess class for SqlServer. So you need to change this to DefaultConnection

That's must be enough

BTW: if you like project please follow it :)
Aug 12, 2013 at 5:46 AM
Edited Aug 12, 2013 at 5:47 AM
If I did those 2 things that you mentioned, the users are in the MongoDB database and the Todo lists in the Sql Server DB. Which is quite the logic effect if I think about it. In my opinion, neither InitializeSimpleMembership nor any ..Context should influence the logic. There might be something related to the fact that the app if calling those methods asynchronously (it's an Ajax based app) and the provider is not initialized/loaded in those cases. This seems to be the main difference between the Internet App template and the Single App template, from the architectural point of view.
Aug 13, 2013 at 6:46 PM
Anyone any idea? Thank you!
Aug 13, 2013 at 10:01 PM

I thought you resolved your issues. Here is fixed solution:

Aug 14, 2013 at 7:52 AM

Unfortunately it has the same issues as before. The same issue is still there, what changes should I be looking for?
Aug 14, 2013 at 7:59 AM

I double checked. Everything works fine. Please look for mistake on your end... Version that includes fix is 1.6.7-beta.

Aug 14, 2013 at 8:30 AM
Where do I get that version from? I have cloned in mercurial and have version 1.6.1
Aug 14, 2013 at 9:13 AM
From nuget or from repository. Your cloned version must work the same as it s working on my local.
Aug 14, 2013 at 10:07 AM
Unfortunately it doesn't work for me. I have tried on 2 different systems. Haven't done any changes other than referencing the downloaded/cloned source.
Aug 14, 2013 at 10:48 AM
Edited Aug 16, 2013 at 6:19 AM
Sorry i confused two threads i was replying to. So what is problem with solution i have sent to you? Which errors?